Project

General

Profile

Actions

Bug #595

open

Create a New AOZ Application doesn't open the new app, does not open the Project tree at the position of the new program, the selected name is not used for the source, etc. (see details)

Added by Brian Flanagan over 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Target version:
Start date:
11/26/2020
Due date:
% Done:

0%

Estimated time:
1:00 h
Affected version:

Description

Example:

Click the "Create a New AOZ Applicaiton" in the toolbar.
Enter a name for your new application: (I chose "A Test".)
Use the defaults on the rest of the "Create a new AOZ Application" dialog box.

Problem 1. At this point you may notice that you do NOT see your new program in the editor.
Problem 2. You'll also notice that the new application's folder has not been opened and made visible in the Project tree.
Problem 3. If you manually open the folder, you'll notice that instead of "A Test.aoz", you'll find a main.aoz
Problem 4. If you select that file, and attempt to transpile, AOZ will hang.*
Problem 5. A manifest.hjson is added to the resources folder of the application.  THIS is what makes the transpiler hang.
Actions #1

Updated by Brian Flanagan over 3 years ago

NOTE: This problem exists in the macOS version.

Actions #2

Updated by Brian Flanagan over 3 years ago

  • Assignee set to Baptiste Bideaux
  • Affected version changed from Beta 2 to 1.0.0 (B5)

Re-tested in 1.0.0 (B5) Partially fixed. (Items 3-5 are working now.)

Thanks for removing the validator.js and correcting the manifest for macOS.

However... items #1 & #2 on the list still exist:

Problem 1. At this point you may notice that you do NOT see your new program in the editor.
Problem 2. You'll also notice that the new application's folder has not been opened and made visible in the Project tree.

Actions #3

Updated by Brian Flanagan about 3 years ago

Re-tested in 1.0.0 (B8) - macOS

Problems 1 & 2 still exist.
Problem #3 is back again.

-- Problem #4 and #5 no longer apply.

There are also new issues:

  1. The resources folder is usually not created.
  2. The manifest file is not found.
  3. The last part of the New dialog box is over-written by some red text.
    (This also happens in the Windows version.)
Actions #4

Updated by Brian Flanagan about 3 years ago

  • Subject changed from Create a New AOZ Application doesn't open the new app, does not open the Project tree at the position of the new program, the program will not transpile, the selected name is not used for the source, and manifest.hjson is added to the resources. to Create a New AOZ Application doesn't open the new app, does not open the Project tree at the position of the new program, the selected name is not used for the source, etc. (see details)
Actions #5

Updated by Brian Flanagan about 3 years ago

6 The resources folder is usually not created.
7 The manifest file is not found.
8 The last part of the New dialog box is over-written by some red text.
(This also happens in the Windows version.)

Actions #6

Updated by Brian Flanagan over 2 years ago

  • Status changed from New to Resolved
  • Target version set to 1.0.0 (B9) u16

I'm not sure when this was fixed, but it's working now! :-)

Actions

Also available in: Atom PDF