Project

General

Profile

Actions

Bug #4

closed

Can't reload index.html (locally) after the AOZ app ends.

Added by Brian Flanagan over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Target version:
-
Start date:
01/17/2020
Due date:
% Done:

0%

Estimated time:
Affected version:

Description

I can no longer reload an AOZ application (index.html) in the web browser after the application ends.
Attempting to do so results in a "Your file was not found" error, even though the local URL is identical.
Instead, I have to re-compile the code, even if I haven't changed anything.

Error:
Your file was not found
It may have been moved or deleted.
ERR_FILE_NOT_FOUND

This used to work in previous versions.


Files

TestPrint.png (5.96 KB) TestPrint.png Program ended successfully. Brian Flanagan, 01/19/2020 07:35 AM
YourFileWasNotFound.PNG (5.15 KB) YourFileWasNotFound.PNG Your file was not found. Brian Flanagan, 01/19/2020 07:35 AM
Actions #1

Updated by Baptiste Pillot over 4 years ago

  • Affected version set to 0.9.2.5
Actions #2

Updated by Baptiste Pillot over 4 years ago

  • Assignee set to Francois Lionet
Actions #3

Updated by Francois Lionet over 4 years ago

  • Status changed from New to Feedback

Need info Brian, please... In such 'fuzzy' cases of bugs, such a description is not enough for me to work.
I happens sometimes for me, when an application does really something wrong to Chrome OR the transpiler gets stuck in a loop and in fact does not liberates the files, so the next compilation cannot save them.
You say 'always'... ??!! very strange.

Please provide the zipped folder of the application that does it... :)

Updated by Brian Flanagan over 4 years ago

You won't need a zipped folder. Yes, I mean EVERY AOZ application does this now.

They didn't before. Before, I could reload the page, or retype the URL in the browser, and it would run again.

Test program:

Print "Test"

Compile and run.
Then after you see:

"The page says

Program ended successfully."

If you try to reload the page in Google Chrome, you'll see:

"Your file was not found

It may have been moved or deleted.

ERR_FILE_NOT_FOUND"

Actions #5

Updated by Baptiste Pillot over 4 years ago

Could not reproduce : I run the program, then press F5 and... it runs again. No problemo (versions 0.9.2.6 to 0.9.3.1).
That's why Francois asks you "the maximum of files coming from your system". It allows to have a precise look to the manifest, the files you generated, etc.
Thanks :).

Actions #6

Updated by Anonymous over 4 years ago

Nope. It still fails, but I found the issue. Apparently it has to do with HOW the page is reloaded.

I was just clicking in the address bar and hitting Enter... a perfectly valid method of reloading the page, and which worked before in AOZ, but doesn't in the more recent versions. If, however, I use the F5 key as you did, it works. This is weird, since both should do the same thing... and they did before.

If you still need the manifest, etc., I can send it, but I don't think it will be relevant. Try it by clicking in the address bar and hitting enter, and I think you'll see the same results.

For now, I'll just use the F5 key, but this should still be fixed! It's an annoyance, since on many laptops, (like mine), I have to use a special modifier key to use a function key... and the function keys are tiny. It's just easier to click and hit enter!

Actions #7

Updated by Brian Flanagan over 4 years ago

I've identified the problem. It is a bug in Google Chrome. Firefox, Opera, and EDGE are all good. Chrome is the culprit.

Reloading the page with F5 is OK. DOUBLE-clicking on the address bar and hitting enter is OK. If, however, you single-click on the address bar, this highlights the URL (as it should), however, hitting enter from there will cause Google Chrome to improperly escape the URL, converting the % to %25, so the reload fails. All the other major browsers work fine. Only Chrome fails. (Yes, I plan to report this to Google, if I can figure out where to submit bug reports!)

So... you can mark this one Resolved or Closed, whichever you find more appropriate.

Actions #8

Updated by Brian Flanagan over 4 years ago

FYI, I did report this bug to the Chromium development team. They acknowledged the bug, and indicated that it has been corrected in the current beta version of Google Chrome... so the next update of Google Chrome should correct this problem.

Actions #9

Updated by Brian Flanagan over 4 years ago

I just verified that this problem has been corrected in the current BETA version of Google Chrome: 80.0.3987.66.

Actions #10

Updated by Baptiste Pillot over 4 years ago

  • Status changed from Feedback to Rejected

Verified with Google Chrome "stable" version 79.0.3945.130 : I have no problem.

Ok, if it solved in Chrome beta 80.0.3987.66, it will be probably right on the next release of Chrome. Good work :).

I close it with "rejected" : it seems it was not a problem of AOZ, but of Chrome beta version.

Actions

Also available in: Atom PDF