Project

General

Profile

Actions

Bug #733

open

Actor command can't find images in subfolders of AOZ Drive. (This used to work.)

Added by Brian Flanagan about 3 years ago. Updated about 3 years ago.

Status:
Feedback
Priority:
High
Target version:
-
Start date:
04/23/2021
Due date:
% Done:

0%

Estimated time:
4:00 h
Affected version:

Description

Example:

Actor "beam",image$="beam.png" // This USED TO work, but now fails with Image Not Defined error.

The actual path for the above file is:
AOZ Drive/resources/images/Asteroids/Magic/beam.png

Actor will only find image files in the root of the images folder:
AOZ Drive/resources/images

Actions #1

Updated by Brian Flanagan about 3 years ago

  • Priority changed from Normal to High
Actions #2

Updated by Brian Flanagan about 3 years ago

  • Assignee set to Baptiste Bideaux
Actions #3

Updated by Baptiste Bideaux about 3 years ago

  • Status changed from New to Resolved

It's solved. The Transpiler goes through all the files in AOZ Drive and takes into account the first file found in the list.

Actions #4

Updated by Brian Flanagan about 3 years ago

  • Affected version changed from 1.0.0 (B7) to 1.0.0 (B8)

Re-tested in 1.0.0 (B8) macOS

The problem is worse than before.
Now it won't find ANY files on the AOZ Drive!
For example:

Actor "magician",Image$="magic.png"

...causes the transpiler to crash.

...Compiler error: crash during compilation: Pass: 2, crash at line 0, column 35!  The "path" argument must be of type string.  Received type undefined...
Actions #5

Updated by Brian Flanagan about 3 years ago

  • Status changed from Resolved to Feedback
Actions #6

Updated by Brian Flanagan about 3 years ago

NOTE: This appears to work fine in Windows, but fails in macOS.

Actions

Also available in: Atom PDF