Project

General

Profile

Actions

Bug #645

closed

ASCII Man Reloaded errors out any time the pac guy collides with an enemy.

Added by Brian Flanagan over 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Target version:
-
Start date:
01/29/2021
Due date:
% Done:

0%

Estimated time:
2:00 h
Affected version:

Description

The program loads and starts properly, however it crashes as soon as the pac guy collides with an enemy.
(This involves many different blocks of code - but probably has the same underlying issue.)

(See attached snapshot of one of the errors.)


Files

ASCII_Man_Reloaded_Collision.png (80 KB) ASCII_Man_Reloaded_Collision.png One of many errors on collisions. Brian Flanagan, 01/30/2021 03:45 AM
2021-04-03 03.08.12.mov (5.01 MB) 2021-04-03 03.08.12.mov Video showing one of the collision errors. Brian Flanagan, 04/03/2021 08:19 AM
Actions #1

Updated by Brian Flanagan over 3 years ago

  • Estimated time changed from 1:00 h to 2:00 h

Retested. Collisions still broken as of 9 Feb 2021.

(Tested in both Windows & macOS versions.)

Actions #2

Updated by Brian Flanagan over 3 years ago

Re-tested in 1.0.0 (B7). All collisions with enemy still fail.
(Added a video to illustrate the problem.)

Actions #3

Updated by Phil Bell over 3 years ago

The problem is with these 2 lines in the CHECK_COLLISIONS: section of the code

px = SCRXOFF + PCX + (PX * MAPCELLWIDTH)
py = SCRYOFF + PCY + (PY * MAPCELLWIDTH)

px,py and PX,PY are not the same because the case is different, but the result of this code is updating the PX and PY variables values.

Renaming px and py fixes the issue. I should probably not have been coded it this way, but it is valid in AOZ.

Phil

Actions #4

Updated by Brian Flanagan almost 3 years ago

  • Status changed from New to Closed

I'm not sure when, but this was fixed a long time ago! (re-tested anyway it works!)

Actions

Also available in: Atom PDF