Project

General

Profile

Actions

Bug #111

open

Default font & size used for Text command are wrong.

Added by Brian Flanagan over 4 years ago. Updated over 2 years ago.

Status:
New
Priority:
High
Assignee:
-
Target version:
-
Start date:
02/03/2020
Due date:
% Done:

0%

Estimated time:
2:00 h
Affected version:

Description

Example: Help_49 from AMOSPro_Examples disk.

Any text displayed using the "Text" command is too large and uses the wrong font.

The items using a normal "Print" command work fine. These are the numeric value
of the X and Y coordinates. Everything else uses Text, and is wrong.

(See snapshot.)


Files

Help_49.PNG (35.6 KB) Help_49.PNG Brian Flanagan, 02/03/2020 08:27 PM
Actions #1

Updated by Brian Flanagan over 4 years ago

  • Affected version changed from 0.9.3.2 to 0.9.5.1

Problems still exist in 0.9.5.1

Actions #2

Updated by Brian Flanagan over 3 years ago

  • Priority changed from Normal to High
  • Estimated time set to 2:00 h

It's broken even worse now.
Not running at all.

Actions #3

Updated by Brian Flanagan over 2 years ago

Re-tested in 1.0.0 (B10) u16
Still fails in Amiga manifest.
The Text command seems to work in AOZ mode... but that's with modified code...
...and even the modified example code for Tutorial 49 still doesn't work properly.

The text displayed with Print doesn't match the rest of the display as it should.
Also, the cursor doesn't always change properly.

Actions #4

Updated by Brian Flanagan over 2 years ago

  • Affected version changed from 0.9.5.1 to 1.0.0 (B10) u16
Actions

Also available in: Atom PDF