Project

General

Profile

Actions

Bug #1070

closed

Wont execute after transpile MAC in browser if .iff files are in application folders

Added by malcolm harvey over 1 year ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
01/16/2023
Due date:
% Done:

0%

Estimated time:
Affected version:

Description

(Amiga manifest). (Mac).
If you have a picture filename.png and also the same name filename.iff in either your filesystem/application folder or assets folder, aoz will run the transpiler, but at the end it will stop and just bring up a blank message window.
It wont go onto to execute and run the full screen browser.
Also, even though you may have selected your picture in your code, using load image "gameinventory.png",2 etc, just the fact that the same filename.iff was in there in the same folder, it stops executing to bring up the browser at the end and run. Again, but if you delete all the .iff files in your filesystem/application folder and also the assets folder it will run. Just leave the .png files alone in there, then it will execute.
So yes some issue with the .iff files in there as well. Should not be.
.

Actions #1

Updated by malcolm harvey over 1 year ago

This could also be related and caused by the same thing as 1074.
.

Actions #2

Updated by malcolm harvey over 1 year ago

Ticket 1074 rather.

Actions #3

Updated by malcolm harvey over 1 year ago

  • Assignee changed from AOZ Studio Team to Francois Lionet
Actions #4

Updated by malcolm harvey over 1 year ago

Also at this point, even with just .iff files in the filesystem/application folder in amiga manifest mode, on a pc windows, the instr is working eg:, load iff "",0 but currently using the Mac OS, using that instr now, causes it to just stop after transpiring with a blank message window poping up at end. Again only on the Mac.

Actions #5

Updated by malcolm harvey over 1 year ago

Another oddity, interestingly I had to change only on the mac client version,
eg: using load iff "gameinventory.iff",2 will only work now on windows not the mac version for amiga manifest anyways. It also does not like, load image "gameinventory.iff",2
All you get is it stops at the end of the transpile with a blank message window.
.
But if you then change this to load image "gameinventory.png",2 it will run fine in the mac browsers ok.
So seams version 38/39 had this same issue only on the mac the windows ver u38/39 runs load iff "gameinventory.iff",2 ok.
So some issue with the load iff and also the .iff file format again only on Mac in U39 now anyways.

Actions #6

Updated by malcolm harvey about 1 year ago

Same issue with U43.

Actions #7

Updated by malcolm harvey about 1 year ago

Ok, I have removed the duplicate files names problem because BaptisteB pointed out, if you have the same name in a folder but with a diff ext it will clash and it will be the same name, so that issue has been resolved, but the only is is yes, below...
..
eg: using load iff "gameinventory.iff",2 will only work now on windows not the mac version for amiga manifest anyways.
All you get is it stops at the end of the transpile with a blank message window.
.
But if you then change this to load image "gameinventory.png",2 it will run fine in the mac browsers ok.
So seams version 38/39 had this same issue only on the mac the windows ver u38/39 runs load iff "gameinventory.iff",2 ok.
So some issue with the load iff and also the .iff file format again only on Mac in U39 now anyways.
The same issue is there on the Mac version U43...
..

Actions #8

Updated by malcolm harvey about 1 year ago

  • Assignee changed from Francois Lionet to Baptiste Bideaux

Baptiste, this was the issue currently I spoke about with the loading amiga .iff files MAC only. (Windows ok).
Wont load, guru meditation or other error. See last note above. Thankyou.

Actions #9

Updated by malcolm harvey about 1 year ago

Same in u43.

Actions #10

Updated by malcolm harvey about 1 year ago

This can also happen in windows U44 version, it might be better described here in the discord blog.
But yes again it can stop at random.
https://discord.com/channels/653893653940404224/707482106313441350/1119085113205080136 ``

Actions #11

Updated by malcolm harvey about 1 year ago

re: U44...More to the last note above..
In my latest test again with my latest code on windows and mac U44, they are both the same now, oddly they will load .iff files, but it will only execute at the end of the transpile if there is no more than about the first 13.iff files (from my set) in the filesystem/application folder (using amiga manifest), if u don't put the .iff files in there that are missing, it executes (but of course your code complains they are not there when it runs), but if you add the rest in there after the first 13 of them, say I might have 25 in total (so now i have 25 .iff files in there), which are listed in my main.aoz code, it will just stop transpiling at the end or along the way and popup with a blank message window and no errors.
Again if you replace all these with .png files it works correctly and executes, so again some issue with just using .iff files. This is the same in windows or mac U44 currently.

Actions #12

Updated by malcolm harvey 7 months ago

The main current issue that we have currently is that using Load iff "image.iff", for example in Windows or Mac Gurus now and it will only work if using Load image. Seams to have occurred on the release v1.0 of aoz jan 2023, it was working prior to this 37 or prior I believe.
So you cant use this for Amiga manifest in aoz using load.iff files or using the amiga transpiler either then for AMOS Pro conversions.

Actions #13

Updated by malcolm harvey 3 months ago

  • Status changed from New to Closed

Seams now with the test beta1 U45, its loading .iff's again ok no file error or guru (windows or mac). Not sure why but also loading them ok again from fileysystem/application folder with multiples in the folder. Also seams to work loading .iff files in aoz -> amiga and via the amiga transpiler and in amos pro.
Close ticket.

Actions

Also available in: Atom PDF