Project

General

Profile

Actions

Bug #828

closed

Get image error Amiga Manifest

Added by malcolm harvey over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
09/19/2021
Due date:
% Done:

0%

Estimated time:
Affected version:

Description

Using the code below gives...Get Image illegal or error function call , 11-57
This worked fine up until and including Update 15 Beta 8. (Amiga Manifest mode).

six1imagex=245 //Get Inventory Object.....
six1imagey=68
Get Image 2,1,six1imagex,six1imagey To six1imagex+10,siy1imagey+10

Actions #1

Updated by David Baldwin over 2 years ago

Check code, the error is a new thing, caused by a negative height. Your example code has a error - the last var siy1imagey SHOULD be six1imagey, and so is zero, so is generating an illegal height of -57.

Actions #2

Updated by malcolm harvey over 2 years ago

  • Status changed from New to Closed

malcolm harvey wrote: (This was a miss print in only one section of code, oddly enough it
was correct in all other places. But it seams as dave & phil point out now, the last two parameters
should be ammount to grab x,y or 10,10.

Using the code below gives...Get Image illegal or error function call , 11-57
This worked fine up until and including Update 15 Beta 8. (Amiga Manifest mode).

six1imagex=245 //Get Inventory Object.....
siy1imagey=68
Get Image 2,1,six1imagex,siy1imagey To six1imagex+10,siy1imagey+10

Actions

Also available in: Atom PDF