Project

General

Profile

Actions

Bug #263

closed

Sprite Col Bob Col

Added by Anonymous over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
02/28/2020
Due date:
% Done:

0%

Estimated time:
Affected version:

Description

Sprite Col and Bob Col do not appear to work


Related issues 1 (0 open1 closed)

Is duplicate of AOZ Studio Beta - Bug #20: Bob Col(1) not doing anythingClosedFrancois Lionet01/18/2020

Actions
Actions #1

Updated by Baptiste Pillot over 4 years ago

  • Related to Bug #20: Bob Col(1) not doing anything added
Actions #2

Updated by Baptiste Pillot over 4 years ago

  • Related to deleted (Bug #20: Bob Col(1) not doing anything)
Actions #3

Updated by Baptiste Pillot over 4 years ago

  • Is duplicate of Bug #20: Bob Col(1) not doing anything added
Actions #4

Updated by Baptiste Pillot over 4 years ago

  • Assignee set to Francois Lionet

The same for me.
This little piece of code does not work for me :

Bob 1, 32, 32, 1
Bob 2, 40, 40, 1
If Bob Col(1)
    Print "boom"
End If
  • Compilation : ok
  • Run : Internal error at line: 4, column: 1.
  • Console JS : "Cannot read property 'bobCol' of undefined at Application.blocks. (application.js:45)
  • The line of code into application.js : if(!(this.aoz.sprites.bobCol(1,this.aoz.currentScreen,)))

Seems that this.aoz.sprites is undefined.

Actions #5

Updated by Francois Lionet over 4 years ago

  • Status changed from New to Resolved
  • Target version set to 0.9.6.1

Fixed!

Actions #6

Updated by Baptiste Pillot over 4 years ago

  • Status changed from Resolved to Closed
Actions #7

Updated by Baptiste Pillot over 4 years ago

Tested with this little code :

#splashScreen:false
Bob 1, 20, 20, 1
Bob 2, 24, 24, 1
Bob 3, 100, 100, 1
Print Bob Col(1) ' true
Print Bob Col(3) ' false

It seems good. I close.

Actions

Also available in: Atom PDF